timwheatley.org
Tim Wheatley is a British-born Legal Resident living in Tinley Park, Illinois with his American-born wife, Sheila. He works for Image Space Inc.

Tim's interests include Photography, PC-based gaming, World History, World Travel, Politics, Auto Racing, Sim Racing, Aquariums and the NFL.
Find out more about rFactor 2.
Find out more about iGP Manager.
The hosting company used by this Web site.
Free 14-Day Trial of EVE-Online.
Main header image by Jim Boswell.

©1999-2014 Tim Wheatley - Unless obviously not.
closeThis post was published 6 years 1 month 15 days ago.
Information might not be up-to-date.

I recently formatted and decided to try Windows XP SP3. When it came to installing the drivers for my soundcard, everything seemed to go as normal, but when I restarted – no sound.

After much searching I found that the “PCI Device” listed in the Device Manager was infact my soundcard – but it wouldn’t recognise the drivers and wouldn’t even let me force the correct driver to install on it – it seems my computer was totally unable to support the soundcard all of a sudden!

Well, I ran this Microsoft Installer and instantly the hardware was found and XP correctly assigned the correct drivers to the card – phew!

I am very likely to need this in the future (and it’s hard to find it on the ‘net!) so I have uploaded it to this post.

kb835221.exe (642KB)

159 thoughts on “Realtek HD Audio Fix for Windows XP (SP3) – KB835221

  1. Dustin says:

    Dude, THANK YOU. I have a Toshiba laptop and a machine I built myself, both running Intel boards with Realtek HD and XP SP3. This was maddening until I found your post. Thanks again!

  2. Tim says:

    You’re welcome – glad to help!

    I’ve just gone back to SP2 unfortunately, my computer wouldn’t boot and I can’t figure out why. :(

  3. Chris says:

    Dude…after 9 hours of searching and frustration..and goin to go back to vista in a fit of rage…i found this file at the end of the tunnel
    thanks MAN!!!!!!

  4. Chris says:

    This fixed a Hp Pavillion dv6000/Dv6315ca model

    conexent audio would not install…untill after this patch…

  5. Tim says:

    You’re welcome, sorry it took you so long to find. :(

  6. webstranger says:

    THANK YOU. I was about to install SP2 version insyead of SP3.
    Problem was with MSI Neo2-FR, but look like it with all Realtek HD audio

  7. Veer Pratap says:

    Thanx man.. i was almost going to buy new sound card for my PC until i found this post… thanx alot man…..

    but still facing problem with my Pinnacle PCTV tuner card…

  8. German says:

    thanks a lot man.. I’ve just desperated.. almost formatted my pc and install sp2 again without having it. :D :D- thanks a lot again.. it was very very useful.

  9. Tim says:

    The latest version of SP3 from Microsoft includes support for HD Audio now. I edited the post above.

  10. Waylander says:

    kb835221.exe (642KB)

    Thankyou so much man tried every1 of these hotfixes and th only 1 work was urs. i can finally sleep lol cheers dude

  11. Ehsan says:

    THANKS DUDE, THANKS U SO MUCH. HUHH… NOW I CAN RELAX. I WAS SO WORRY BECAUSE AFTER INSTALLING SP3, MY SOUND DRIVERS DIDN’T MATCH WITH IT, I WAS GOING TO INSTALL THE SP2 AGAIN BUT FORTUNATELY AT THE END OF THIS DARKNESS I LUCKILY FOUND UR POST AND IT REALLY HELP ME IN GETTING OUT OF THIS HELL. SO THANKS AGAIN DUDE. KEEP IT UP!! MAY GOD BLESS U AND GIVE U EVERY RIGHT THING WHATEVER U WANT.

  12. Tim says:

    THANKS DUDE, THANKS U SO MUCH. HUHH… NOW I CAN RELAX.

    You’re welcome. Frankly I think it’s shocking they miss something this huge in testing. :(

  13. Roger says:

    kb835221.exe (642KB)

    You are a lifesaver.

    I love you man.

  14. Bocha says:

    kb835221.exe (642KB)

    I will never forget yu help. thanks.

  15. Srikanth n says:

    kb835221.exe (642KB)

    hi, thanks for the help, i was able to resolve the problems. i dont have words for thanking you.

    regards
    srikanth

  16. John Thompson says:

    All I can say is, you are a legend! Two hours trying in vain, and your fix sorted it straight away.

    Respect

  17. aNAND says:

    Thanks — thankyou very much

  18. Thanks! says:

    kb835221.exe (642KB)

  19. Aldousbee says:

    THanks man! It works

  20. Tim says:

    The name of the kb835221.exe file has been changed to _kb835221.exe because some rude person decided to use all my bandwidth by hotlinking to the file. I have changed the link in the post above so normal visitors should not notice anything different.

  21. gysh says:

    Tnx too much.. Helpful:)

  22. Jan-Willem says:

    Thanks man,

    After a few frustrating hours i found your blog with
    the solution for sound on my Sony TZ31.

    Thanks again,

    JW

  23. aditya says:

    thanks man,
    you really help

  24. Ramzi says:

    I was having the same problem and solved with your solution and help.

    Thanks very much, my sound is working perfect now.

    Best regards

    Ramzi Hassan

  25. Tim says:

    Ramzi as-in, Ramzi from Illinois? :)

  26. Rothguard says:

    fix works
    AWSOME

    why is this not on windows update? sp3 is a joke no wmp 11 no ie7 and no .net2 shame shame shame

    thanks again for the fix

  27. tharindwije says:

    wow ur the man boss! thanx a million!

  28. SkullKrusha says:

    I LOVE UUUUUUUUUUUUUUUUUUUU .. i have been searching for hours THANK U!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  29. dutchturk says:

    TY soo much after 2 days searching ehats the problem with the sound
    now it works on my lapter acer aspire 5315, ty ty ty t y

  30. salah says:

    guys i am sorry but i installed and got nothing
    why
    i have msi p6n platinuem and the sound still i there a strategy to download this file or what since i am still on the problem with sound realtek you know and thanks in advance

  31. Marco says:

    THANK YOU VERY VERY MUCH!!

  32. Sulistio says:

    Tank You for this valuable info., it just works like a charm
    Really save my time

  33. heinz says:

    3 words for you :

    I LOVE YOU !!!!!!!!!

    (–.–)

  34. Testerbtw says:

    I formatted my pc and installed new fresh copy of XP SP3…I have no sound and i installed WDM_A406 and WDM_R229 Realtek drivers ,still nothing.
    Hopefully, this will fix the problem :D:D:D:D:D…going to test it and bring the news…

  35. Naga says:

    I really cant leave without telling you Thanks…OMG! Hours of search came to an end after seeing your post…awesome man..gr8..3 words for you I love youuuuuuuu!

  36. Mannu says:

    Will anybody kindly tell me the whole process to fix this sound problem in xp sp3 and how to use this kb835221.exe .i will be very much thankful.

  37. help says:

    thanksss dudeeee!!!

  38. Athrun says:

    Thanks you sooooooooooooo much for this . I have been trying to find a solution , but nothing is better than your 600KB file :)

  39. Zafar Karimov says:

    Thank you so much. I am appreciate it.

  40. Sahithi says:

    still my problem is not solved, please suggest me wat else i can do to install my Audio drivers successfully with Windows XP SP3

  41. PRiTAM says:

    this is universal audio driver hotfix. it auto detects the realtek hi-definatin audio.

  42. AllyRae says:

    So it didnt work for me. :( bummer

  43. KY says:

    God bless you..

  44. Amit says:

    Tim.. Thanks a lot for your post !! I was facing the same problem after installing sp3 i.e. audio device was not being detected.. but after installing the patch you mentioned and then installing the realtek drivers again, the issue got resolved.. Thanks a lot again !!

  45. Tim Wheatley says:

    I can’t believe this post is still helping people! You’re welcome!

  46. Esther says:

    Thank you ! you save the day XD!!!

  47. Saket says:

    Thanks Bro !!!!!!!!!!

  48. Sunil says:

    thanks dude u r just absolutely fantastic , keep posting such stuffs , bec it took ahell out of me to find the PCI driver

  49. HIDAM says:

    I am trying to see if it can solve my sound problem

  50. Leo says:

    I Love You!!!!

  51. Kiki says:

    Thanks!!! it worked

  52. Exactly what I was searching for, thankyou for putting up.

  53. Ranjith says:

    Hi tim. Thank u for ur timely help.

  54. EJ says:

    Im so happy, Thank UUUUUUUUUUUUU

  55. musaddiq says:

    thanks thanks thanks

  56. deep says:

    thanks buddy

  57. Andries says:

    Haha, and still the thank you’s are coming in. Thanks Tim :)!

  58. upamanyoo says:

    thanks dude. u are really a life saver. god bless u.wish to see more solutions from u……cheers

  59. Martin says:

    Thanks a lot!!!!

  60. Dutt says:

    This is answer for HP dv6314tx – Conexant High Definition audio driver for XP3

    PROCESS
    install HP UAA
    Install KB835221 patch for XP3

    Thank you….Love you man… :-)

  61. John says:

    Thanks mate :)

  62. Majid says:

    Tim and Dutt
    Thanks a lot,
    I didn’t work on my HP Pavilion dv2700 Notebook.
    I installed both HP UAA and KB835221, but still no result.
    please any help

  63. Majid says:

    I didn’t –> It didn’t

  64. Arky says:

    Thnx a millllllllliiiiiiiiiiiiioooooonnnn

  65. abhijeet says:

    THANKS MAN I was searching the audio driver for my laptop last 3 days thanks for POST

  66. wguru says:

    Now if only Realtek HD Audio only allowed users to work around the issue of not being able to hear the in-process captured video (by allowing users to select the audio output for the input), ref. capture devices like KWorld’s PVR Plus which either it’s software and/or Realtek’s never got it right. When I try to change RHDA’s playback to the input, the tab changes to output (so no reversal is enabled and still I cannot hear the in-process capturing video’s audio, until after the capturing is stopped and I play the vid back). Surely somebody must also have seen this annoyance and discovered how to fix it, as KWorld has absolutely no interest in fixing the issue (even when they still supported their dongle’s 2005 product).

  67. Kulvinder Singh says:

    thanks dude this porb fucked my mind for 9 dayzzzz finaly its working great thanks again….

  68. Kim says:

    OMG!!!!!!!!!! You are my hero.

  69. thejusr says:

    thanksalot dude…

  70. Lee says:

    Thanks. After setting up two previous Intel Atom based MB’s I knew there was an HD sound issue using Win XP but could not remember how to fix it on the latest MB. Did all of the service pack updates to no avail. Intel was no help either.

  71. Mehdi says:

    thats good Man . thank you (mehdi from iran).

  72. paul kenneth says:

    my only problem when i install realtek HD audio driver is that it is always failed to install.

  73. asok says:

    its not working for me help me i dont want to reinstall OS

  74. Jaynoose says:

    All i can say is thanks you, thank you,thank you. with just couple of click, bamm. Thanks a bunch

  75. bikram says:

    thank u man….it really helped me…i spend my whole night just to solve it….

  76. giancarlo says:

    My friend , you are a genius.
    I have spent weeks f…ing around to have the cursed thing working.
    Thanks a lot

  77. No s0und says:

    not working for me…
    download and install the software but still not working for me.
    pls help me
    Thanks

  78. Bob says:

    Genius!! Thank you so much. This totally worked. I’ve been struggling with this for days.

  79. Sony VAIO VGN-CR25G says:

    Ah, mine has the realtek HD audio codec. would work for a while then I would have to re-install the driver. Recently wasn’t working at all.. THANKS A MILLION it’s working again now with patch KB835221, will just see for how long… :-)

  80. Murali says:

    hi. i reboot my system last week. the audio is not woking.. now i want audio driver for my lap. the model is Realtek RTL8139 Family.. thank u.

  81. Murali says:

    i want sound driver for my lap. the model s Realtek RTL8139 Family.

  82. Tim Wheatley says:

    You’ll need to search for that driver. This is a fix to make drivers work properly.

    And anything not fixed by this, I cannot help with.

  83. Samarth says:

    Thanks man.I would love to give a thumbsup.

  84. sam says:

    thanxxxxxxxxxxxxx a lot dude.. you helped me out from frustration of many hours..thanx a lot

  85. Natman says:

    You sir are a fucking god. I wish I could shake the shit out of your hand right now. Im saving this patch on 45 cds I swear. Thanks again man. Hella good kudos

  86. Maveric says:

    This is a whiz-bang fix man. And it’s almost four years you rolled this fix out. Not getting a sound from your Laptop could send one into a depression as you frustratingly stare at the thing like a stone. You saved another soul.

    Another thanks from Singapore.

  87. Nathan says:

    Cannot thank you enough. I genuinely thought there was no solution after 5 months searching frantically until I somehow cameacross this. Great Work!!!!

  88. Chandan says:

    Thank u very very much…………………..

    Thanks a lot………………………

    u don’t know how a lot u help lots of people who have this problem.

    Thank u
    Thank u
    Thank u
    Thank u
    Thank u
    Thank u

  89. Gustavo says:

    gracias..

  90. desai says:

    The latest version of SP3 from Microsoft includes support for HD Audio now. I edited the post above.

  91. stovokor says:

    THANK YOU, MASTER :)

    I am deeply grateful for your fantastic page and the invaluable help you keep providing!!!!!!!!!!! After a few days and night of uneven struggle agains the ideas clash between Microsoft and Realtek, I came across your page, et voila!!!!! I had to clear old installations, of course (did so in rescue mode) – but it worked only after installing the patch you provided, all previous attempts ended in a depressing fiasco. Any time you are in Poland you are heartily invited for a crate of beer or a wagon of vodka :)
    No joke :)

    I hope you don’t mind sharing this web page with a couple of my friends :)

    All the best from Poland, and may you live long and prosper :)

  92. Gerald says:

    tx bro,i used it on my macbook n running good

  93. anup says:

    very good fail i like u r good working fail thanks a lot god bless u

  94. Gerald says:

    tx a lot bro

  95. kodok says:

    this is what i’m looking

    thanks man and sory for my bad english

  96. Phillip says:

    Thank you!

  97. M K Lee says:

    Hi from Malaysia. You’re a life-saver! We use this old PC to watch youtube videos and podcasts on HD TV. Could not solve the no-sound problem for 6 months. Upgraded from sp2 to sp3; installed all sorts of drivers; thought the on-board sound card had died, changed to USB card – still nothing. Until I found your post today. Have paid thousands for Microsoft licenses for all my office PCs and this is the support we get. Thanks a million.

  98. Yogesh says:

    Thanks dear.
    It worked for me.
    I upgraded my OS to Win XP SP3 and sound was not working on my ACER Extnsa 5620. I updated ur pack and now sound working fine

  99. Neonentity says:

    THANK YOU! This cured a previously intractable problem with Realtek HD on a Gigabyte GA-MA785GM-US2H mainboard running MCE.

  100. Chris Sadler says:

    It’s 01:23 here in UK and for over TWELVE HOURS I’ve been trying to stop a BSOD being caused everytime I tried to install sound drivers on Foxconn 760GXK8MC mobo. Your fix worked straight away. THANK YOU!!!

  101. romel says:

    thanks dude

  102. emjaye says:

    Thank you so much, you are indeed a life saver! I was lucky I was able to come across your solution before I almost gave up. I came into my senses and tried using the realtek keyword instead of the error I got from my computer that took me so long to find the fix. You have no idea how many people you’re helping here, to think that this was posted 4 years ago already. Appreciation coming from the Philippines :)

  103. Waqas says:

    Tim thanks alot, great job, u help us all. thanxxxxxxxxxx

  104. Yatsui says:

    Now you is my God …XD thank’s

  105. Menika Jenita says:

    Thanx a lot bcoz of this file my laptp got sound device working properly..

  106. zelma says:

    I’d installed that update but still I’m not able to see new hardware found in my device manager.
    my sound card is inbuilt into mother board..
    when I install drivers I can’t see anywhere that. only add and remove that appear.

    anyone help me?

  107. Mujahid says:

    Thanks a lot for your help.

  108. Lorne says:

    Thanks…..worked just great. Can’t tell you how great this fix is. Went to all kinds of sites…..yours is the only one that fixed the problem.

    Thanks again.

  109. navya says:

    i am unable to fix the problem even now i have even tried above kb835221.exe link but still the same problem i ahve even tried to reinstall the realteck couple of times and run the .exe file still no use pleaseeeeeeeeeeeeeeee help me to get out of this problem

  110. Faith HENRY says:

    After Reading all comments, I know and do have FAITH that this is my answer.
    I just downgraded a Toshiba Satellite Laptop from Win 7 to Win XP SP3.

    Installed Audio Realtek High Def Audio driver and there was no sound! Thank you in advance!

    I’ll keep you updated after running this patch!

    Cheers!

  111. Heather says:

    Thank you Tim, I searched for a fix for this to no avail until I came across your download. It Worked. Thanks Again

  112. kaprice says:

    thank you so much !!! this fixed a problem in a minute !

  113. Akshay says:

    Hello Mate,

    Thanks for the post … its work for me also.
    Great and Thanks a lot once again.

    Regards
    Akshay.

  114. WTF!!!!!!!!!!!!!! says:

    U FUCKING SAVED MY LIFE!!!!!!!!!!!!!!!!!!!!!!
    COME HERE AND I WILL GIVE YOU A KIIIIIIIIIIIIIIISSS!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    OH MY GODNESS!!!!!!!!!!!!!!!!!!!!!!!!
    UNBELIIIIIIIIIIIIIIIIIIIIIIVABLE!!!!!!!

  115. GULSHAN KUMAR SAHU says:

    u have done very god job dr…….i heartly thanx u yrrrrr….

  116. Kaushal says:

    It will be a little thing to say you thank you sir. because without this stuff my pc had become an unvaluable thing .thanks a lot of you brother. you have uploaded such a precious thing. i found it after nine hour searching on the
    internet. thanks again. i shall be thankful to you. wow……
    awesome upload which internet couldn’t provide.

  117. sasa says:

    thanks man, it’s the best!

  118. AAAAAAAAAAAAAAAACHHHHHHHHHHHHHHHHH says:

    No Works in 2000%

  119. dinra says:

    great …all that required was this small driver andI went from pages to pages on hp forum downloading unwanted stuff…at last this wroked like magic and i am able to use sp3 on machine meant for hp branded xp2

  120. Peter Doyle says:

    Cannot believe this file is still here as this is now 2012 Anyway – Tried every driver possible with no luck for Audio on Packard Bell Easynote after installing bloody SP3 as the auido driver worked with Sp2 – Soon as I installed your kb835221 audio returned – You are a lifesaver

  121. Bob says:

    Nearly 4.5 years later and this file is still saving the day. Thanks for putting this up. It fixed my problem immediately.

  122. etherealsunshine says:

    Still helping people. I had this problem pop up about 6 months ago. I’ve had SP3 installed for at least two years, probably more. I had no audio except when I played files in Windows Media Player…including no system sounds–I noticed it when my custom .wav was no longer playing for new e-mails. I’ve tried to find a fix off and on for months!!! Thank you, Tim!

  123. John Zander says:

    This Really Helps! I’m searching audio drivers on about 1-2 hours then i found this.. thanks for this blog@

  124. ma says:

    Thank you. I spent six months without sound on XP-SP3 slipstreamed 4Gb RAM, with realtek hd audio unable to install, now it works.
    thanks again.

  125. Aneesh says:

    you are my god !!! thank you sooo much !!!!!

  126. sam muriuki from kenya says:

    thanks guy en God bless the work of your hands. I love uuuuuuuuuuuuuuuu. saved me alot. thanks.

  127. ranv says:

    Thanks a lot dude.. Its working truly awesome…

  128. Ker says:

    YOU ARE JUST……… FUCKING AWESOME DUDE!!!, TONS OF TNX, THIS SMALL EXE WORKS INSTANTLY.

  129. RBW says:

    Amazing! I’ve spent hours trying to get the audio working on a friends Toshiba M115-S3094…deleting drivers, re-installing the Realtek drivers, and even though this post is four years old I took a chance…thanks…

  130. chris says:

    5 years later and the thank yous continue

    so i will add to the list

    THANK YOU

  131. anass says:

    Thanks a lot

  132. chucks03 says:

    Thank goodness you save me man….

  133. calstatedisneyland says:

    I have to throw in my thanks too… years later!!!!

  134. Troy says:

    Super thanks. I had this fix before but lost it.

  135. aklas_parveen says:

    Really great! I’ve spent much time to get the audio working on my PC by deleting drivers, re-installing the Realtek drivers.But noluck.I am about to format, luckly i found this.I just downladed the “kb835221.exe” from the above link and run it.Now it’s working fine.

    thanks for this blog..

  136. Acer AO 725 user says:

    This works, but when I restart the computer, no sound again. please help me to solve the problem.

  137. Aki says:

    after hours searching the web i found this an its still not working for me !!!!

  138. bob says:

    Thanks. You saved me after I reinstall SP3 on my mom’s old notebook and I had the sound problem.

  139. Pritam says:

    ur post helped me a lt !!!!!!!!

  140. gabby says:

    years later..tx dude…

  141. Samson Wordwood says:

    DUDE, you are my savior, a Bodhisattva of Silicon Valley. It was YOU, benevolent sage, who lit the torch of reason before my eyes. And it was YOU, wise leader, who drew me out of pitch black silence. With wisdom and power, YOU delivered me back into the realm of waveforms, to bathe once again in oases of audio bliss. \Nameste

  142. akhilesh says:

    thank you friend

  143. simon says:

    I am very happy with it!

  144. arindam pal says:

    i have a problem, my mother model LGA775I65GV, I am install xp service pack 3,Download driver C-Media_XP64_XP_2K_ME_98(AC97Integrate003)
    it still not install, when i install it there show for more information please contact http://www.cmedia.com.tw
    please any one help me to fix this problem ??????????????????

  145. hari says:

    hi dude ….I install a KB835221.exe /n aaage kya karo

  146. hari says:

    plz help me

  147. MaF says:

    I FUCKING LOVE YOU!!….i’ve spent hours and more hours, getting mad, crazy, one step from breaking the fucking computer, depressed….and now, you are the best dude ♥

  148. mohammed awais says:

    thank u very much

    it’s really helpful
    again thank u very much

  149. Likmaiballs says:

    I just wanted to say lick my balls Dude – everybody loves you

  150. locount says:

    thank you brother you are my live safer

  151. Aaron says:

    Unbelievable. It said device working correctly, best driver installed, no problems with the device and yet I had no sound. This update worked immediately, didn’t even have to reboot. After four hours of dos beeps, there was a little pop and it said device installed and ready to use. Thanks a lot, man!

  152. gregf says:

    on wixpsp3 have installed SigmaTel udio codec and your file but no sound.
    plz help.

  153. Cataclismo says:

    My problem is that on Windows XP SP3, after I install the driver the windows does not start. It blocks when loads. I even installed that update…still nothing.
    Any ideas?

  154. Ali says:

    Thanks very much dude ..

  155. Eric C says:

    I don’t believe it…
    I’m in the process of rebuilding an old PC I was given (HP Pavilion a1110y) and the windows xp pro sp3 did this very thing to me – and the drivers are nowhere to be found on the Web – except for this patch which I found by sheer luck!
    Even if this post is never read, I still have to say thanks…

  156. Paul Wilde says:

    Thanks so much for this fix, I’d spent days trying to get a fix on the internet and kept getting all these “Driver Manager” software running. Keep up the good work I’ll keep coming back when I get a problem in future !!!
    Paul – Manchester, UK

  157. Bono says:

    Very amazing!
    I’ve spent hours trying to get the audio or sound card driver working on my friend’s laptop, Toshiba Satellite L745… I was deleting drivers, re-installing the Realtek audio drivers, Conexan audio drivers, and even though this post was published 6 years 22 days ago.I took a chance…thanks a lots…

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>